The Digi Cloud Operations Team has resolved the performance degradation issue. Corrective measures have been successful; normal performance has been restored. Thank you for your continued business and patience during this incident.
Posted Mar 20, 2026 - 12:54 CDT
Monitoring
The Digi Cloud Operations Team has implemented a fix and continues to monitor the application.
Posted Mar 20, 2026 - 11:48 CDT
Update
The Digi Cloud Operations team is working on a corrective action. We will provide further updates as available. Thank you for your continued business.
Posted Mar 20, 2026 - 11:14 CDT
Identified
The Digi Cloud Operations Team has identified the problem and is implementing a fix. Further status updates will be provided as available. Thank you for your continued business and patience.
Posted Mar 20, 2026 - 10:24 CDT
Investigating
The Digi Cloud Operations Team has observed a performance degradation impacting device connections and is currently working to resolve the issue. The result of this issue is that it could take a little longer than normal for a device to connect to the application. Updates will be provided to this page as more information becomes available. Thank you for your continued business and patience.