The Digi Cloud Operations Team has resolved the performance degradation issue. The team continues to monitor the application and will provide updates if anything changes. Thank you for your continued business and patience during this incident.
Posted Jun 01, 2025 - 21:52 CDT
Monitoring
The Digi Cloud Operations team is working to improve the performance issues. Customers may notice slightly elevated latency in looking up device or account information in the application. We will provide updates as more information is available. Thank you for your continued business and patience.
Posted Jun 01, 2025 - 21:16 CDT
Investigating
The Digi Cloud Operations Team has observed a performance degradation impacting the application tier and is currently working to resolve the issue. Updates will be provided to this page as more information becomes available. Thank you for your continued business and patience.