Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 15, 2025 - 12:00 CDT
Scheduled
The Digi Cloud Operations Team will be performing scheduled maintenance on the Digi Remote Manager UI starting on May 15, 2025 at 17:00 UTC. The maintenance window is planned to be no more than 30 minutes. Users may experience a brief disconnect/reconnect as we update the UI. There will be no impact to device connections. No action is required on your part. Thank you for your continued business!
Posted May 13, 2025 - 10:34 CDT
This scheduled maintenance affected: Application and UI.